升级到WordPress 2.8请谨慎


费了一个晚上终于搞定,中间重新安装了好几次,最后看了别人的帖子才明白原来是插件冲突的问题 …… 感觉上2.8比2.7x在速度上的确有所提升,但由于这个版本的变化较大,从文件结构到数据库都有不少改变,所以也容易出现一些问题,特别是和一系列的插件冲突。 目前已知和它冲突的主要插件有:

use-google-libraries
all-in-one-seo-pack(据说最新版本已修正这个问题)

导致的问题主要有:页面空白、无法切换可视化和HTML编辑器等,另外由于文件结构的变化,还导致一些插件无法使用,对一些较为复杂的模板也有所影响。所以,如果要升级一定要备份好原先数据,另外好像数据库升级时候略有一点遗留问题,如果条件允许的话,最好是备份后删除原先内容重新安装后导入数据(导入数据不包括链接列表、附件、小工具中的文本等,注意做好备份)。总之,由于版本内容变化很大,升级尽量谨慎为妙。

已有 6 条评论

  1. 类似的问题也有碰到,两个插件致页面空白或出错
    不过还好,主题做完,才作的升级,基本顺利

    好久不来,招呼一声^_^

  2. @所以说,这个就不太清楚了,反正我用的时候发现和use-google-libraries冲突的问题是的确存在的;all-in-one-seo-pack没有用,但是听说它的问题也有吧。

    @Mr.Lao3,哈哈,没这么恐怖,升级是件好事,注意一点也没什么不良后果,反正升级不升级只是时间的问题。

  3. 这俩插件我都有用,似乎没有类似问题呀

  4. 我也升级了,感觉没有期待的那么大~

  5. 我就有用这俩插件,没发现类似问题啊。
    倒是发现2.8与 DB Cache 有冲突

  6. 已經升級了~還有沒有得救啊

我也说两句儿......